読者です 読者をやめる 読者になる 読者になる

むずかしいことはわかりません

いろいろ書いてるみたいな

観念してAndroidSDK1.6R1へ入れ替え

http://developer.android.com/intl/ja/sdk/1.6_r1/index.html
http://developer.android.com/intl/ja/sdk/1.6_r1/upgrading.html
電話機本体も1.6へアップデートしたことですし、SDKも入れ替えしようということで入れ替えを敢行。
とはいえ、やったことと言えば、ダウンロードしてきて解凍して、EclipseSDKへのPATH書き換えてADTツールをダウンロードし直すという作業です。

日本語化してあるEclipseなので日本語表記ですが…。

ウィンドウ→設定→AndroidSDKロケーション

入れ替えが終わってるかの確認は、「ターゲット名」に1.6、API Levelが4のものが存在するかどうか。

HELP→ソフトウェア更新→http://dl-ssl.google.com/android/Eclipse/

Developer Toolsの下のDDMSと開発ツールにチェック入れてインストール(I)押してやる。
入れ替えた終わったバージョン見たら「0.9.3v200909031112-12945」でした。

そんな感じで入れ替え終わったようなので、なんかコンパイルしてみよう。
ちなみにプロジェクトのプロパティを開いて、ターゲットをGoogleAPIsの1.6(API Level4)にしないと新しいSDKにならないでしょうから、必要に応じてチェックする場所入れ替えてみてください。